IPB

Bienvenue invité ( Connexion | Inscription )

 
Reply to this topicStart new topic
> Un son dans une page html ? -- Encore un problème de son, c'est déjà une énigme ! :@ !
Sarya
* 25/10/06 à 13:42
Message #1


Apprenti
Group Icon

Groupe : Members
Messages: 35
Inscrit : 07/09/2006
Membre No. : 23 350
Niveau Atteint: 75 !



Bonjour !!

Je voudrais savoir s'il existe un moyen d'intégrer un son à une page html ( c-a-d comme celle que veux Swan pour les énigmes.) de manière à pouvoir disposer du bouton d'indice, du code source etc etc ( alors que si je faisait juste un lien vers son.mp3 je ne le pourrais pas, si ? non).

Le must du must serait de pouvoir mettre un "player", et c'est pour cela que j'avais pensé a une animation flash, manque de po, je suis nul ne flash, je ne possède pas le programme, rien, nada.

Si quelqu'un veux bien se proposer pour me faire cela qu'il m'MP, je lui enverait le son a mettre dans l'animation, ou si quelqu'un a une autre/meilleure idée, je suis preneur.

Merci de votre attention. smile.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
FRiZ
* 25/10/06 à 13:59
Message #2


Gros sot modo
Group Icon

Groupe : Modérateurs
Messages: 2 050
Inscrit : 23/07/2005
Lieu : Vire
Membre No. : 2 977
Niveau Atteint: En attente du 94



Je pense que le tuto de Swan répond parfaitement à tes désirs. (Re)lis bien la fin.


--------------------
Signature
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Sarya
* 25/10/06 à 14:24
Message #3


Apprenti
Group Icon

Groupe : Members
Messages: 35
Inscrit : 07/09/2006
Membre No. : 23 350
Niveau Atteint: 75 !



CITATION(FRiZ @ 25/10/06 à 14:59) *

Je pense que le tuto de Swan répond parfaitement à tes désirs. (Re)lis bien la fin.

OOoh merci FriZ !

Je suis désolé, honte a moi de pas avoir lu cette fin de tuto tongue.gif !

J'ai encore un problème.
J'ai copié ce que Swan a mis dans son tuto, mais ça ne marche pas.
Déja Notepad++ n'interprête pas cette ligne que tu HTML.
Pourtant j'ai copié sans aucune fautes, j'ai essayé avec ou sans les guillements, avec ou sans </embed> après ma ligne ...
Dans le doute voilà exactement ce qui est copié :
<embed src=son.mp3 heigh=60 width=144 hidden=false autostart=false>

Mon sentiment c'est qu'embed n'est pas un balise existante, pourtant je crois savoir que Swan s'y connait ( et puis j'ai cherché sur Internet, ça existe ... )

Si quelqu'un a une idée ...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
FRiZ
* 25/10/06 à 14:38
Message #4


Gros sot modo
Group Icon

Groupe : Modérateurs
Messages: 2 050
Inscrit : 23/07/2005
Lieu : Vire
Membre No. : 2 977
Niveau Atteint: En attente du 94



T'as essayé d'ouvir la page html avec ton navigateur ?
Peut-être que notepad++ ne reconnait simplement pas la balise <embed>.

Sinon, dans les normes W3C, je crois, si je ne me trompe pas, qu'il faut plutôt utiliser la balise <object>.
Dans le doute tu peux toujours mettre les deux :

<object data="son.mp3" type="audio/mp3" width="144" height="60">
<param name="src" value="son.mp3"/>
<param name="controller" value="false" />
<param name="autostart" value="false"/>
<embed src="son.mp3" heigh="60" width="144" hidden="false" autostart="false">
</embed>
</object>


Je suis pas sûr que ça marche comme ça, mais tu peux toujours tester ^^


--------------------
Signature
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Sarya
* 25/10/06 à 20:06
Message #5


Apprenti
Group Icon

Groupe : Members
Messages: 35
Inscrit : 07/09/2006
Membre No. : 23 350
Niveau Atteint: 75 !



CITATION(FRiZ @ 25/10/06 à 15:38) *

T'as essayé d'ouvir la page html avec ton navigateur ?
Peut-être que notepad++ ne reconnait simplement pas la balise <embed>.

Sinon, dans les normes W3C, je crois, si je ne me trompe pas, qu'il faut plutôt utiliser la balise <object>.
Dans le doute tu peux toujours mettre les deux :

<object data="son.mp3" type="audio/mp3" width="144" height="60">
<param name="src" value="son.mp3"/>
<param name="controller" value="false" />
<param name="autostart" value="false"/>
<embed src="son.mp3" heigh="60" width="144" hidden="false" autostart="false">
</embed>
</object>
Je suis pas sûr que ça marche comme ça, mais tu peux toujours tester ^^


Non, ça ne marche pas sad.gif

Le embed n'est pas recconu, toujours pas, j'ai fait vérifié la page par le validator du W3C et il me signale qu'aucun attribut n'est donné pour src, width etc etc ... alors que y'en a !!

J'avais essayé d'ouvrir avec FF et IE, mais sur les deux ça ne fonctionne pas sad.gifsad.gif.

Au s'couille !


EDIT : C'est bon !! Grand merci à toi Friz, j'ai fais quelques modifications sur ce que tu m'a donné et ça marche.
Il ne me reste que le placement, et les paramètre a règler, mais ça devrait pas poser de problèmes.
Encore merci !



EDIT : voici le code utilisé finalement, peut etre mon aventure servira a quelqu'un !
<object data="son.mp3" type="audio/mp3" width="750" height="500">
<param name="src" value="son.mp3">
<param name="controller" value="true">
<param name="autostart" value="false">
</object>
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 utilisateur(s) sur ce sujet (1 invité(s) et 0 utilisateur(s) anonyme(s))
0 Membre(s):

 






Version bas débit Nous sommes le : 22/10/17 à 05:49